Which operative system does my smartphone need to use Click'n Go?

In order to use the Click’n’Go mobile app, the main requirements are to ensure that your mobile is connected to the Internet, Bluetooth and an appropriate operating system. (Android 5.x or higher/ iOS 9.3 or higher)

We recommend downloading the Click’n’Go mobile app as soon as your booking is confirmed.

Remember to activate notifications for the Click'n Go APP in order to keep up to date with your booking details at all times.

Need to talk?

If you need assistance with your booking, our staff will be happy to help you.

Our locations

Looking for a rental location? Check our map to find all the InterRent locations.